Black screen when taking train to New Vegas

General discussion of Tale of Two Wastelands
User avatar
TheModHead
Posts: 6
Joined: Fri Jan 04, 2019 10:07 pm

Black screen when taking train to New Vegas

Post by TheModHead » Fri Jan 04, 2019 10:35 pm

Whenever I take the train to New Vegas, the game loads for less than a second after saying "Three Years Latter" and then it tells me its picked-up some radio stations, but it just stays on a black screen. I assume its not loading the map, but when I create a new save and start in in the Mojave Wasteland, the game acts like normal!
I have some mods installed, but I have deactivated all of them at once, but the same thing happens.
I know there's a bug that keeps tranquility lane from loading on AMD graphics cards, as I had to find a fix for that, so is this something like that?
I tried looking on google, but I couldn't find anything related to this. Oh yeah, incase these have anything to do with it, I know the game was a bit buggy with liberty prime, and crashed once while I was following it to project purity, and at the end of Who Dares Win the helicopter never appeared at the end (I had to use cheats to complete the quest)
Both Fallout 3 and New Vegas are from GOG, and I am using a Dell Optiplex 755 with an AMD Radeon HD 5450 graphics card updated to the latest drivers (Yes, I know, I should upgrade to a newer computer, I hate when people point that out as if it takes a genius to know you should upgrade from a computer that was made in 2006 with a Graphics Card made in 2010)

User avatar
pintocat
Posts: 536
Joined: Sun Apr 07, 2013 12:50 am

Re: Black screen when taking train to New Vegas

Post by pintocat » Sat Jan 05, 2019 12:03 am

Post your load order

viewtopic.php?p=23665#p23665

User avatar
TheModHead
Posts: 6
Joined: Fri Jan 04, 2019 10:07 pm

Re: Black screen when taking train to New Vegas

Post by TheModHead » Sat Jan 05, 2019 12:46 am

My load order is:
FalloutNV.esm
DeadMoney.esm
HonestHearts.esm
OldWorldBlues.esm
LonesomRoad.esm
GunRunnersArsenal.esm
Fallout3.esm
Anchorage.esm
ThePitt.esm
BrokenSteel.esm
PointLookout.esm
Zeta.esm
CaravanPack.esm
ClassicPack.esm
MercenaryPack.esm
TribalPack.esm
TaleOfTwoWastelands.esm
YUPTTW.esm

User avatar
pintocat
Posts: 536
Joined: Sun Apr 07, 2013 12:50 am

Re: Black screen when taking train to New Vegas

Post by pintocat » Sat Jan 05, 2019 2:43 am

What mods did you have installed before? Just because they're deactivated now doesn't mean they didn't mess something up while they were active

User avatar
RoyBatty
Posts: 5970
Joined: Sun Apr 27, 2014 10:26 am
Location: Vault 108

Re: Black screen when taking train to New Vegas

Post by RoyBatty » Sat Jan 05, 2019 2:53 am

If a mod changed the VCG01 startup quest for new vegas, you'll stuck in that holding cell forever.
Image

User avatar
TheModHead
Posts: 6
Joined: Fri Jan 04, 2019 10:07 pm

Re: Black screen when taking train to New Vegas

Post by TheModHead » Sat Jan 05, 2019 3:12 am

The mods I have installed (along with the links, and in load order) are:
SpeedyResources.esm (https://www.nexusmods.com/newvegas/mods/39551) (required by Vault 76)
Vault 76.esp (https://www.nexusmods.com/newvegas/mods/59418) (A mod for TTW)
UHNV.esp (https://www.nexusmods.com/newvegas/mods/37884)
Player Robot Factory.esp (https://www.nexusmods.com/newvegas/mods/58741)
MCPipBoy2000MK6.esp (https://www.nexusmods.com/newvegas/mods/65980) (I have the findable version installed)
Coops.esp (https://www.nexusmods.com/newvegas/mods/47844)
Level100PerkPerLevel.esp (https://www.nexusmods.com/newvegas/mods/43055)
ttw_speedtreefix.esp (I can't find the link I downloaded from, but it fixes tranquility lane on TTW so it wont crash with AMD graphics cards)
These are the only mods I have ever had installed after installing TTW, and by extension, these are the only mods I have ever used on this save file

User avatar
RoyBatty
Posts: 5970
Joined: Sun Apr 27, 2014 10:26 am
Location: Vault 108

Re: Black screen when taking train to New Vegas

Post by RoyBatty » Sat Jan 05, 2019 3:56 am

Level100PerkPerLevel.esp is what broke your game

This mod recompiled ALL script in the game, broken, do not use.
Image

User avatar
TheModHead
Posts: 6
Joined: Fri Jan 04, 2019 10:07 pm

Re: Black screen when taking train to New Vegas

Post by TheModHead » Sat Jan 05, 2019 12:49 pm

So I'm assuming I have to use a new save, cause disabling it still leads to the black screen
nvm, apparently theirs a fix for this
NVM I can't find the darn fix

User avatar
RoyBatty
Posts: 5970
Joined: Sun Apr 27, 2014 10:26 am
Location: Vault 108

Re: Black screen when taking train to New Vegas

Post by RoyBatty » Sat Jan 05, 2019 1:38 pm

You should be able to load a save before you took the train.
Image

User avatar
TheModHead
Posts: 6
Joined: Fri Jan 04, 2019 10:07 pm

Re: Black screen when taking train to New Vegas

Post by TheModHead » Sat Jan 05, 2019 2:34 pm

I've been doing that. After the first time I took the train, I loaded the auto-save from when I entered the train, and saved it. Even when I disable the mod, when I go to New Vegas, it loads for less than a second, and stays on the black screen. I tried using the Vault 76 mod to go to New Vegas to see if that was working, and it does, though the train is meant to be used after you've already gone to New Vegas and thus doesn't load any of the scripts the TTW one does. (I didn't save after this, as the mod creator says it will break the game if you don't use the TTW train first)

Post Reply