NVSE extender incompatibility with 3.2+

General discussion of adult mods. Please read the rules before you post.
thephatsass
Posts: 4
Joined: Fri Oct 19, 2018 10:08 pm

NVSE extender incompatibility with 3.2+

Post by thephatsass » Sun Dec 30, 2018 3:49 am

Having NVSE and JIP LN pre-installed seems to be messing with NVSE extender (NX) which causes you to CTD when trying to load a save if you have something that uses NX such as sexoutNG. Anyone gotten around this yet? I imagine it must be a dependency issue with TTW's version of NVSE, but this is hardly something I know about.

User avatar
RoyBatty
Posts: 6521
Joined: Sun Apr 27, 2014 10:26 am
Location: Vault 108

Re: NVSE extender incompatibility with 3.2+

Post by RoyBatty » Sun Dec 30, 2018 4:30 am

Literally don't care about NX or sexout. Sexout isn't compatible with 3.2 anyway.

The NVSE that comes with TTW is exactly the same as the 5.1b4 you can download from the nvse.silverlock.org site.
Image

User avatar
pintocat
Posts: 545
Joined: Sun Apr 07, 2013 12:50 am

Re: NVSE extender incompatibility with 3.2+

Post by pintocat » Sun Dec 30, 2018 5:19 am

JIP LN and NVSE are both required for TTW 3.2, so having them packaged with TTW 3.2 makes sense.

If there's a problem with NX, someone over there might need to dig up the source code and maintain it or something.

DoctaSax
Posts: 6
Joined: Wed Aug 14, 2013 7:29 pm

Re: NVSE extender incompatibility with 3.2+

Post by DoctaSax » Sat Jan 26, 2019 6:18 pm

Just to clear up the matter, the issue was with NVSE's method of loading plugins, and got exposed to due TTW's having a high index number. Somehow we got it fixed on NX's end, of all things.

Unsure why anyone would think Sexout itself is incompatible with TTW.

User avatar
RoyBatty
Posts: 6521
Joined: Sun Apr 27, 2014 10:26 am
Location: Vault 108

Re: NVSE extender incompatibility with 3.2+

Post by RoyBatty » Sat Jan 26, 2019 6:20 pm

NX was keeping a pointer to the command table, problem was purely with NX. None of our plugins do that, so it wasn't an issue and they all play nice together and with every other plugin. NVSE needed no change really, just NX needed to fix this, why it even does that is anyone's guess, but prideslayer isn't around anymore to ask.

The incompatibility was because of NX.
Image

DoctaSax
Posts: 6
Joined: Wed Aug 14, 2013 7:29 pm

Re: NVSE extender incompatibility with 3.2+

Post by DoctaSax » Sat Jan 26, 2019 6:26 pm

The wild, early days of writing nvse plugins, no doubt.

User avatar
RoyBatty
Posts: 6521
Joined: Sun Apr 27, 2014 10:26 am
Location: Vault 108

Re: NVSE extender incompatibility with 3.2+

Post by RoyBatty » Sat Jan 26, 2019 11:00 pm

Should update mods to use JIPLN instead :)
Image

smashly
Posts: 9
Joined: Mon Nov 26, 2018 1:52 am

Re: NVSE extender incompatibility with 3.2+

Post by smashly » Mon Jan 28, 2019 12:24 pm

JIPLN has pretty much everything NX does and more..
JIPLN even has an undocumented AuxVarGetFltCond condition function to access an AuxVarSetFloat value on any object ref at index 0.
Basically AuxVarGetFltCond would be the equiuvilent of NX_GetQVEVFL
So you can do dialogue and package conditions based on per actor ref just like you could in NX.

The good thing with JIPLN version of the condition function is it works on placeatme objects/actors..
The NX version fails to maintain values on placeatme refs if you reload your game as any placeatme ref drops its NX values.

I actually updated my own personal adult/follower mod to use JIPLN instead of NX.
Even though I had some teething probs converting my code initially, I haven't looked back since doing so.

DoctaSax
Posts: 6
Joined: Wed Aug 14, 2013 7:29 pm

Re: NVSE extender incompatibility with 3.2+

Post by DoctaSax » Thu Jan 31, 2019 6:04 pm

Any change to the framework to switch methods would have to come with changes to a few dozen mods whose authors aren't around anymore to do it or give permission to do it to whoever would feel inclined to update all that, which isn't me. Moving forward with new mods depends on being able to rely on old stuff to keep on truckin'.
NX vars are fine for what we did with them, and up until this recent niggle have been utterly reliable.

Danico_
Posts: 4
Joined: Sat May 25, 2019 9:40 pm

Re: NVSE extender incompatibility with 3.2+

Post by Danico_ » Tue May 28, 2019 10:01 am

NX works fine for me

Post Reply