Page 1 of 2

Game crash upon loading tranquility lane BUG (SOLVED)

Posted: Thu Dec 20, 2018 3:34 am
by nexusmodsforme
FIXED - As noted by RoyBatty below this is a known error related to AMD card but in my case is present with an NVIDIA card. Chucksteel created a fix and attributes the problem to speedtree crashing when entering Tranquility Lane and Oasis it was caused by the speedtree effects that make the leaves move. I still have a greyed out fallout jumpsuit but that doesn't seem to be related to the problem as unlikely as that sounds for the moment.

Link for the fix can be found here and should be posted at end of load order

I still have no idea what caused this to occur as on previous playthroughs I was able to access Tranquility lane and Oasis without issue but if I find the file or change that caused this I will post another update.

Everything below this line is related to solving the problem before the solution was found and can be ignored unless interested in the process of discovery.
Update 1: Ok so after a fresh reinstall of both fallout 3 GOTY and FNV (I even deleted the remaining folders and files after uninstalling them) and TTW I started a new game went through the vault tutorial and upon exiting the vault consoled demigod mode and headed right for vault 112. Sure enough, soon as I get into the tranquility machine and tranquility lane starts to load I get CTD. This is with no mods. Could this be a bug related to not doing the quest line in order?

UPDATE 2: Ok so no dice on the questline coherency attempt. It doesn't seem to matter. Also attempting to teleport directly into tranquility lane results in CTD.
This is a picture of my MO2 launcher Image

One thing I noticed that I had not before is that the jumpsuit for vault 112 is greyed out not sure if that is just the designation for quest items or if it is related to the bug Image

Had a game crash when attempting to load tranquility lane. During the loading page, I could hear the inventory removal sound and the game would then CTD. Attempted to remove mods one by one with no success in finding the offending mod. I am reinstalling TTW and attempt to reload the save with a clean install to see if it will allow me to continue.

Mods and load order as follows
Trait Expansion Addon [TEA] - TTW.esp
The Mod Configuration Menu.esp
The Weapon Mod Menu.esp
JIP Improved Recipe Menu.esp
Immersive Minigames.esp
Project Nevada - Core.esm
Root 'n Loot.esp
Another Interior Mod.esm
TTW FlashlightNVSE.esp

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 9:57 am
by Postal-Dude
Did you already try to start a new game with a clean save with no mods installed and then tp to TL? You can also use TTW Quickstart to speed up the process and skip the vault.
It should usually work then.

If not...

- Either a hardware issue (very unlikely)
- Maybe mod or ini change leftovers
- Broken game & ttw files, maybe try a reinstall of everything, also do a clean redownload in Steam or use the GOG version also don't forget the 4GB patch if needed
- Weird version used to play like German no gore, etc

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 10:22 am
by nexusmodsforme
I did, now I am currently in the process of deleting everything fallout related and MO2 related and reinstalling everything for the second time because the first time I forgot about xlive.dll file lol.

I doubt it is hardware related but I'm concurrent install on my laptop just to be safe and comparing results.
I thought the same thing about the ini files which is why I went through and deleted everything off the fallout files. MO2 has some very strange hidden retrieval processes for pulling mod data off other mod applications. Tracking them all down and breaking the pathways/deleting those files is incredibly frustrating but at the same time I admire the developer's thoroughness in creating a one-stop mod manager to rule them all so to speak I just wish they'd placed more options to find where it is pulling those files from to get to them easier.
I just use the Fallout 3 GOTY edition off steam and Ultimate edition of FNV off steam.

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 11:03 am
by Postal-Dude
Hm. Honestly never really had any problems with MO and think its better than all the other alternatives.

What do you mean by xlive.dll? Isn't this only used for the vanilla FO3 as Games for Windows Live service? You wouldn't need that for TTW/FNV.

Mod Organizer pulls information from:
- Your Fallout inis, which can either be located in documents or, if you use the MO Profile Setting for it, inside the profile folder in Appdata Local Modorganizer
I personally don't use the MO Profile ini setting. Found it annoying plus I was used to the document folder. If you do any changes to the ini, just put them into a FalloutCustom.ini in documents. TTW did this already for you. I am not even sure if Mod Organizer considers the changes in it if you use a own MO ini profile. Just disable the option in the MO profile window. Here you should also enable archive invalidation. For this to work I personally need to use run as Admin on MO.exe. Doesn't properly work without anyway.

- The mods are each installed into a own mod folder created by MO. It also dynamically overrides, merged files like HUD files when the game is loaded, no need to edit anything by hand except of course inis like for Stutter Remover or NVR. UiO also helps with the HUD process. You wouldn't believe what a hassle it was back then to get all your HUD stuff working... I still have nightmares. Just keep in mind that you should also use a logical load order of the mods and not only ESPs. It even shows you when files are overridden. Like when some mods override the same textures. Manage it how you want it to.

- Last but not least of course the installation directory of your Fallout installation. It also shows mods which are already in the folder. I don't recommend this though unless its TTW or of course NVSE. You can actually change the installation directory later on in the profile settings of MO but it usually asks you to add a new game when it can't find its location. Did this too already and it also loaded all my mods properly.

Beside of that I guess its a learning experience for you. Once you figured MO and everything out, it will be the best mod manager you ever had.

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 12:04 pm
by nexusmodsforme
Hmmm so this is most strange. The Desktop version still does not seem to work however the laptop version does without issue. On the desktop version, I played through the vault tutorial until after the goat then teleported to vault 112a and tried to go into tranquility lane before getting CTD on loading. On the laptop, I used quick start you recommended and teleported to vault112 after exiting vault 101 with no issues going into tranquility lane. There were a couple of differences that I noted in the process on the desktop version there was a knocking sound that played throughout the entire time I was taking the GOAT and the vault 112 jumpsuits in the laptop version is not greyed, and the stash options were blank on the desktop but available on the laptop.

I'm kind of perplexed at this point as these were both a clean install of not just the games and the Tale of two wastelands but also MO2 as well. There has to be some kind of another file outside of these that is having an effect on the files themselves but what that could be I have no idea. The only other thing I can think of is the file location itself being in the program files directory so I guess that is the next troubleshooting area that I will try but why that would have such an effect kind of baffles me this far in the game. I'll report back my findings once completed.

The xlive.dll is needed to launch the application before running the install of TTW setup.

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 2:34 pm
by Postal-Dude
Sure the xlive.dll is needed if you going to launch Vanilla FO3. I just don't know why you would do that if you have TTW. Nevermind.

It might be that something inside your Windows system is screwing with the game. I can only recommend to check all drivers for the latest version and also reinstalling some such as the display driver. Beside of that make also sure you have redistributables.

Would be interesting to know your hardware. Back on my old system I had a few audio driver issues with vanilla FO3 I think. Something about DirectAudio, GalaxyAudio, Encoders and the hell knows. But it shouldn't affect FNV and doesn't sound like this is your problem. The knocking part in the G.O.A.T. sounds interesting. Can you record it?

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 2:58 pm
Please learn how to FNVEdit , and remove the Project Nevada Extra Options patch.

and what is that MCLLPPLL100.esp ?

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 5:13 pm
by RoyBatty
This is an old problem with AMD cards, speedtree causes crashes in Tranquility Lane. I'll see if I can find chuck's esp to fix this issue and post it.

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 5:34 pm
by RoyBatty

Re: Game crash upon loading tranquility lane BUG

Posted: Thu Dec 20, 2018 8:15 pm
by nexusmodsforme
PNextraoptions.esp was part of a patch left uninstalled/unchecked for PNcore.esp. Although I understand from one of Roy's posts that MO2 still uses it if it is in the load order I think? Its irrelevant now either way as it along with all other mods, games, steam, MO2 and mod managers have all been removed in this process.

Does FNVedit reference files that would not be located in relation to the game folder/mo2 folder files? If so this may be a promising solution I believe I have used FO4edit a few years ago for modding FO4 and can't recall ever coming across a mod that did that.

I did come across some temp files in windows program data that was being used by MO2 from NMM. (Wouldn't let me delete it while MO2 was being run) so I deleted that stuff as well but the bug persisted when I finally got TTW running.

Roy, I looked up the file that you referenced by chucksteel. I don't think this would cause the greyed out text for the jumpsuit as shown in the screen shot above. I use a Nvidia 1080 card on both desktop and laptop. I will, however, attempt this fix and see if it applies as I have done some funky stuff playing around with infinityeye in my system before while testing multiple monitors with other games. Chucksteel is still active on the nexus it looks like so I also PM'd him explaining my issue to get his thoughts on the matter. We'll see if he responds.

JMTF MCLLPPLL100.esp is MaxCharacterLevel, LevelsPerPerk and Lessons Learned 100 Cap by smashly found here viewtopic.php?f=55&t=6950

I moved the games to another drive last night but MO2 had a conniption fit when I launched it and for some reason was showing all files and dlc in the left-hand side of the screen as well as the right but wasn't picking up that FNV was installed somehow so I deleted that and everything else I could think of even remotely related to the game and now I am just doing a fresh install of everything in the same drive outside of the program files exactly as I have my laptop configured.


Chucksteel replied,


I told him you referenced his file so he doesn't have to track it down. I'll try vanilla accessing tranquility lane and oasis to see if I come across the same problem if this doesn't work once I finish this install of TTW.

He also added Image

Alas, the problem persists. Now attempting Roy's fix. Video of problem

It worked! Praises be upon you Roy! I'll update the OP. I have no idea why this works with NVIDIA card when the fix is for AMD but like I said before my guess it is has something to do with my messing around with infinityeye. Thank you to everyone who made suggestions and stuck with me throughout this process. If anyone knows exactly what to remove or change so I don't have to have this in my load order I'd be interested in trying to make the correction.