Steam Deck Game Mode unplayable frame rate

General help and technical troubleshooting. Ask for help here if you can't find an answer in the FAQ.
Post Reply
User avatar
PhilaCoffee
Posts: 3
Joined: Wed Nov 23, 2022 6:02 pm

Steam Deck Game Mode unplayable frame rate

Post by PhilaCoffee » Wed Nov 23, 2022 6:13 pm

I have the most bizarre bug. When I launch TTW on my Steam Deck in Game Mode it takes forever to load, and when it finally boots to game it's around 5fps. However, if I launch the game from Desktop Mode it's a perfect ~60fps.

This seemingly happened at random, no new mods installed and I'm running the same version of TTW. I was over 60 hours into my play through before experiencing this bug.

I tried a fresh install and I'm getting the same thing. In Game Mode 5fps or less in desktop perfect 60fps.

Any Ideas?

User avatar
RoyBatty
Gary
Posts: 7646
Joined: Sun Apr 27, 2014 10:26 am
Location: Vault 108

Re: Steam Deck Game Mode unplayable frame rate

Post by RoyBatty » Thu Nov 24, 2022 10:26 am

No but someone else has reported they are experiencing low frame rates after dying and reloading a save and have to restart the game.

I've not been able to reproduce this, I use very few mods so I suspect someones mod has bad handling of GetGameLoaded or something.
Image

User avatar
PhilaCoffee
Posts: 3
Joined: Wed Nov 23, 2022 6:02 pm

Re: Steam Deck Game Mode unplayable frame rate

Post by PhilaCoffee » Sat Nov 26, 2022 6:56 pm

If I disable all mods and launch the game I still experience the same bug.

I assume it's something to do with the Steam Overlay, because like I said launching in Desktop Mode on the Steam Deck I have zero issues.

**FIXED**

The issue was FSR. I turned FSR off from the steam overlay and the lagging stopped. I turned FSR back on, and the issue didn't come back. Best I can guess is that there was some driver corruption. I don't play with FSR on anymore. Anyone have this issue I suggest turning off FRS

Post Reply