56 posts / 0 new
Last post
ugsquish
ugsquish's picture
Offline
Last seen: 1 year 5 months ago
Joined: 10/15/2012 - 08:35
Karma: 17
Anchorage pod CTD

I have installed the 1.5b version of TTW. I started OA and every time I get in the pod to start the simulation the game just ctd's on me. Not sure if anyone else is experiencing this phenomenon or not but it is a bug and I'm reporting it. :)

So to be exact. I get in the pod. It closes nicely. The light show goes off and my screen turns white. a small delay then I get the "This program has stopped working" message and I'm back on my desktop.

It may or may not be relevant but I am running Windows 8 Release preview atm.

Category: 

Bug report

Component: 

Quests

Priority: 

Normal

Status: 

Closed (merged)

Project: 

Tale of Two Wastelands

Version: 

TTW 2.0

Reporter: 

ugsquish

Created: 

Wed, 10/24/2012 - 07:49

Updated: 

Thu, 08/29/2013 - 14:23
Edited by: Anonymous (not verified) on 08/29/2013 - 14:23
ugsquish
ugsquish's picture
Offline
Last seen: 1 year 5 months ago
Joined: 10/15/2012 - 08:35
Karma: 17

Issue changes: 

Issue summary: Old » New
Convolution
Convolution's picture
Offline
Last seen: 2 years 5 months ago
Joined: 10/21/2012 - 11:45
Karma: 1
If you have a weapon equipped
If you have a weapon equipped, try unequipping it before sitting in the pod.
ugsquish
ugsquish's picture
Offline
Last seen: 1 year 5 months ago
Joined: 10/15/2012 - 08:35
Karma: 17
The first character I opened

The first character I opened I tried just dropping all my gear. It seems to have worked. I wonder what caused that issue...

sesom
sesom's picture
Team Member
Offline
Last seen: 1 year 10 months ago
Joined: 09/20/2012 - 12:16
Karma: 611
Normally some mod added gear

Normally some mod added gear that interacts with the player per script. They don't like it when they are get stripped off the hard way like the original game does.

chucksteel
chucksteel's picture
Team Member
Offline
Last seen: 7 months 2 weeks ago
Joined: 08/15/2012 - 08:20
Karma: 1842

Issue changes: 

Status: Unverified » Closed (cannot reproduce)
tizerist
tizerist's picture
Trusted Poster
Offline
Last seen: 5 days 13 hours ago
Joined: 09/17/2012 - 03:24
Karma: 285
I'm thinking this is still an

I'm thinking this is still an unresolved bug, and should be re-opened.

I entered the pod to start the simulation, sat down and the faded white screen hung eternally. I tried it on a vanilla NV, and it crashed, like ugsquish said. When I dropped my backwater rifle (does this qualify as 'mod added gear'? - it's from Fallout 3!) on the floor, everything is fine, the sim starts.

So, the game is crashing if the player has a weapon holstered.

Can it go on the to-do list? Maybe TTW could somehow unequip the weapon before the pod sequence?

Oh. And the OP says he has 1.5b version of TTW. The download page only has 1.4 something. What's up with that?

Thanks.

thermador
thermador's picture
Administrator
Offline
Last seen: 1 week 5 days ago
Joined: 08/07/2012 - 07:24
Karma: 1172
Donor

Could be windows 8, but it sounds like it's that certain weapons/items still cause a crash on the pod.

Issue changes: 

Status: Closed (cannot reproduce) » Unverified
tizerist
tizerist's picture
Trusted Poster
Offline
Last seen: 5 days 13 hours ago
Joined: 09/17/2012 - 03:24
Karma: 285
I'm on windows 7

I'm on windows 7

Risewild
Risewild's picture
Administrator
Offline
Last seen: 28 min 58 sec ago
Joined: 10/01/2012 - 02:14
Karma: 3191
Just went back from Point

Just went back from Point Lookout to get the Backwater Rifle so I could try and reproduce this and it happens to me too, after I equipped my samurai sword from MZ and tried it again it worked perfectly, the same when I tried with a caravan shotgun. I will risk it by saying that the Blackwater Rifle is faulty somehow .

Pokepunch
Pokepunch's picture
Offline
Last seen: 1 week 4 days ago
Joined: 01/01/2013 - 12:42
Karma: 120
1.5b? Where can I get this

1.5b? Where can I get this version?

thermador
thermador's picture
Administrator
Offline
Last seen: 1 week 5 days ago
Joined: 08/07/2012 - 07:24
Karma: 1172
Donor
Typo, there is no 1.5b.  All

Typo, there is no 1.5b.  All alpha releases are public, 1.4a is the most current.

jinwoo1601
jinwoo1601's picture
Offline
Last seen: 4 years 8 months ago
Joined: 01/05/2013 - 09:12
Karma: 10
I CTD on exiting simulation.

I CTD on exiting simulation. I have Pipboy Readius which might have caused the problem. i do have the Redaius compatibility patch. 

 

EDIT: disabled Pipboy readius. Still crashes.

 

 

FalloutNV.esm Fallout3.esm DeadMoney.esm HonestHearts.esm OldWorldBlues.esm LonesomeRoad.esm GunRunnersArsenal.esm CaravanPack.esm ClassicPack.esm MercenaryPack.esm TribalPack.esm Anchorage.esm ThePitt.esm BrokenSteel.esm PointLookout.esm Zeta.esm TaleOfTwoWastelands.esm Project Nevada - Core.esm Project Nevada - Cyberware.esp Project Nevada - Equipment.esm Project Nevada - Rebalance.esp Advanced Recon Tech.esm RH_IRONSIGHTS_NV.esm Lone Gunman's Tools of Trade.esm More Perks.esm NVInteriors_Core.esm TTW_InteriorsProject.esm oHUD.esm CINEMATECH.esm dD - Enhanced Blood Main NV.esp dD-Full Screen Blood Instant Remove.esp Better Binoculars High.esp TTW_ReadiusCompatibility.esp Fallout - New FPS (Medium).esp Portable Tent.esp epock.esp NVWillow.esp Project Nevada - Dead Money.esp Project Nevada - Honest Hearts.esp Project Nevada - Old World Blues (No Cyberware).esp Project Nevada - Lonesome Road.esp Project Nevada - Gun Runners' Arsenal.esp AllCompanionsEssential 2.0.esp Advanced Recon Gear.esp Advanced Recon Tech.esp Advanced Recon Gear - Project Nevada.esp Advanced Recon Gear-Locations Doc Mitchell.esp Advanced Recon Range Finder.esp The Mod Configuration Menu.esp FlashlightNVSE.esp FairyRadar.esp The Weapon Mod Menu.esp SignatureWeapons.esp SignatureArmor.esp Holster Gear.esp Holster.esp RH_IronSights_NV_Vanilla.esp HJLLessDismembermentAndExplosionsv100.esp NewVegasBountiesII.esp NewVegasBounties.esp NewVegasBountiesII Fixes - DLCs.esp CNR_Beta.esp CASM.esp theHeroNV_1.1.esp TFH Rugged Race.esp More Perks Update.esp Barrett 98B.esp LeatherBackpack - eng.esp FN SCAR.esp LFox Bottle That Water.esp Anchorage+NV.esp Geonox_Riot_Armor.esp ColtM4Carbines.esp ELECTRO-CITY - Imaginator.esp DYNAVISION 2 - Dynamic Lens Effect.esp Directors Chair.esp BM4A1.esp Readius_NV.esp   Total active plugins: 78 Total plugins: 88   My list of mods.
Risewild
Risewild's picture
Administrator
Offline
Last seen: 28 min 58 sec ago
Joined: 10/01/2012 - 02:14
Karma: 3191
CTD exiting the simulation is

CTD exiting the simulation is a known problem, luckily I found a workaround for it:

Just unequip all the stuff you have equipped after you defeat the chinese guy and before you talk to the general to exit the sim.

jinwoo1601
jinwoo1601's picture
Offline
Last seen: 4 years 8 months ago
Joined: 01/05/2013 - 09:12
Karma: 10
That did the trick. Thank you

That did the trick. Thank you!

 

steviestevens
steviestevens's picture
Trusted Poster
Offline
Last seen: 1 year 4 months ago
Joined: 09/11/2012 - 17:54
Karma: 177
I'm gonna go ahead and close

I'm gonna go ahead and close this since that fix worked. Will make note of the backwater rifle issue though.

steviestevens
steviestevens's picture
Trusted Poster
Offline
Last seen: 1 year 4 months ago
Joined: 09/11/2012 - 17:54
Karma: 177

Issue changes: 

Status: Unverified » Closed (merged)
Pokepunch
Pokepunch's picture
Offline
Last seen: 1 week 4 days ago
Joined: 01/01/2013 - 12:42
Karma: 120
I just spammed F5 to make a

I just spammed F5 to make a quick save when the game loaded, That worked too.

Shadow
Shadow's picture
Trusted Poster
Offline
Last seen: 4 years 6 months ago
Joined: 01/08/2013 - 19:11
Karma: 44
Yeah, I just completed

Yeah, I just completed Anchorage yesterday.  And had a CTD exiting the simulation.  I ended it again, just to make sure it wasn't a random crash, but I still got the CTD.  So the last time I just dropped everything in my inventory and I exited fine.  I didn't have any mod added items in my inventory that could have caused it.

I wouldn't really call a workaround like that a fix though.  The source of the problem should be found, and the issue fixed at the .esm level.

So I'd recommend changing it from fixed back to active.

tizerist
tizerist's picture
Trusted Poster
Offline
Last seen: 5 days 13 hours ago
Joined: 09/17/2012 - 03:24
Karma: 285
Agreed, it's not really fixed

Agreed, it's not really fixed if the game can crash on the player in this way.

thermador
thermador's picture
Administrator
Offline
Last seen: 1 week 5 days ago
Joined: 08/07/2012 - 07:24
Karma: 1172
Donor

Agreed.  Un-fixing this issue.

Issue changes: 

Status: Closed (merged) » Unverified
chucksteel
chucksteel's picture
Team Member
Offline
Last seen: 7 months 2 weeks ago
Joined: 08/15/2012 - 08:20
Karma: 1842
I agree myself, This issue

I agree myself, This issue needs to be left open and active. 

chucksteel
chucksteel's picture
Team Member
Offline
Last seen: 7 months 2 weeks ago
Joined: 08/15/2012 - 08:20
Karma: 1842
Ok guys, I've spent the

Ok guys, I've spent the better part of the afternoon trying to debug the crashes related to the OA Simulation. I do know it has to do with the script that force unequipps the players weapons. I still don't know why the issue only is caused by certain weapons. 

I've tested all Unique and, Preorder pack weapons by adding them one by one to my inventory, equipping them and, activating the pod.

Here is a list of known weapons when equipped will cause a CTD when starting the simulation. 

Unique weapons, 

  1. Backwater Rifle,
  2. Col. Autumn's 10mm Pistol,
  3. Sleepytyme (GRA),
  4. Sydney's 10mm SMG,

Preorder Weapons, 

  1. weathered 10mm Pistol,

Non-Unique,

  1. 10mm Pistol,
  2. 10mm Submachine Gun,
  3. Lever-Action Rifle,
  4. Mr. Burke's 10mm Pistol, 

I haven't tested all Non-Unique weapons only the ones that there Unique counterpart showed the CTD for. I'm Assuming by looking at the list of affected weapons any modded variants will also cause the same CTD. I also assume but, haven't tested yet that having the 10mm Pistol or 10mm SMG (10mm SMG Is not in the sim.) active when the Sim ends is what causes the CTD that some people have when exiting OA. 

For now the only solution I have for this issue is to not have any of these weapons active when you enter the sim. They can be in your inventory just not active, I tested that too to make sure there wasn't an issue just having them on you. 

If you find any other weapons, items that cause a crash on entering the sim please post them here I'm trying to keep a running list of what is causing this bug. 

Edit: I just tested OA with the only weapon on the Crash list. The 10mm Pistol is the cause of the sim exit crash. had the Close quarters package and, with the 10mm I got a CTD but, with the shotgun I exited fine. 

we are looking into ways to resolve this issue.

Risewild
Risewild's picture
Administrator
Offline
Last seen: 28 min 58 sec ago
Joined: 10/01/2012 - 02:14
Karma: 3191
If for some reason you guys

If for some reason you guys can't fix it than maybe have the game unequip the weapon we have equipped at the time of starting and exiting the sim before it strips everything from the player's inventory. That way the game would do what we have to do manually now as a workaround .

thermador
thermador's picture
Administrator
Offline
Last seen: 1 week 5 days ago
Joined: 08/07/2012 - 07:24
Karma: 1172
Donor
Chuck, did you check if it's

Chuck, did you check if it's related to the weapon list NVAllWeapons?  http://www.taleoftwowastelands.com/content/weapons-lists

Maybe those weapons aren't on the list?  I dunno...

sesom
sesom's picture
Team Member
Offline
Last seen: 1 year 10 months ago
Joined: 09/20/2012 - 12:16
Karma: 611
I don't think so. Did a bit

I don't think so. Did a bit of research on this bug and it seems that the combination of additem (ancourage gear & weapons) and equipitem on the player in the quest script is making troubles here, if the weapon is equipped. It's interesting that it only happens with 10mm.  I look further in this issue and see if I can came up with a solution.

sesom
sesom's picture
Team Member
Offline
Last seen: 1 year 10 months ago
Joined: 09/20/2012 - 12:16
Karma: 611
Posted a fix in the usual

Posted a fix in the usual thread.

The crash was caused by removeitem/additem & equipitem on the player in one script (and assumingly one frame) while engine tries to loads a new area (this simply can't do any good ;) ). The removeitem is still in the quest script but I moved the additem and the equipitem to the speech at the beginning of Ancourage. So the engine has a lot of time to change the player and isn't in a critical (loading saving) phase while all this is happening. This fixes btw. only the entry in the DLC. I still have to look what causes the crash on exit (have to play through the DLC first ;) ).

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 4 months 2 weeks ago
Joined: 09/11/2012 - 17:33
Karma: 3778

Issue changes: 

Status: Unverified » Verified
JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 4 months 2 weeks ago
Joined: 09/11/2012 - 17:33
Karma: 3778
I'm going to leave this open

I'm going to leave this open until the exit fix has been created and tested, thanks for that sesom.

jaassu
jaassu's picture
Offline
Last seen: 2 years 5 months ago
Joined: 02/18/2013 - 05:14
Karma: 44
I had also crash in TTW 1.41a

I had also crash in TTW 1.41a when returning from simulation.

Dropping all items and weapons before returning from simulation helped.

sesom
sesom's picture
Team Member
Offline
Last seen: 1 year 10 months ago
Joined: 09/20/2012 - 12:16
Karma: 611
Posted a fix in the usual

Posted a fix fort the leaving Ancorage problem in the usual thread. Team please test.

(Before anyone asks: The fix will be available as soon as it is tested by the team and is then added to the scheduled update of TTW.

Deequiping all items before you talk with Chase at the end of the simulation is a workaround you can use until the fix is publicly available.)

The crash was caused by removeitem equipped items from the player while loading (very similar to the same bug on entering Anchorage). I moved the removing all items from the player to the last conversation with the simulated General Chase which fixes the problem because it's in menumode (the safest place to temper with the player).

Risewild
Risewild's picture
Administrator
Offline
Last seen: 28 min 58 sec ago
Joined: 10/01/2012 - 02:14
Karma: 3191
I was going to test this fix

I was going to test this fix before my laptop drowned in tea now I still am a bit away from reaching the outcasts to test it, but I should be getting there before this weekend if there are no surprises in the way .

sesom
sesom's picture
Team Member
Offline
Last seen: 1 year 10 months ago
Joined: 09/20/2012 - 12:16
Karma: 611
Thanks Risewild. To avoid

Thanks Risewild. To avoid confusion there are two fixes in the "usual thread" one for entering and one (the newer one I uploaded it today) for leaving Anchorage.

Risewild
Risewild's picture
Administrator
Offline
Last seen: 28 min 58 sec ago
Joined: 10/01/2012 - 02:14
Karma: 3191
Ok, will get them both then

Ok, will get them both then :P

Risewild
Risewild's picture
Administrator
Offline
Last seen: 28 min 58 sec ago
Joined: 10/01/2012 - 02:14
Karma: 3191
Ok just tested the enter the

Ok just tested the enter the pod CTD fix and I used the Mr. Burke 10mm pistol and without the fix, CTD as expected, with the fix all nice and smooth Now I will post the rest my testing results soon.

And the exit simulation fix works perfectly too

Both are Risewild approved great job.

 

Just a note, now Dogmeat follows me into the simulation I wonder what happened for it to be there now. And for some reason when I got to the listening post there was some soldiers that belonged to the HQ (I assume) there. A T51b Power Armor soldier, a normal soldier (I think) and one or two American Grease-Monkeys.

Even though this Dogmeat and the soldiers appearing in front of the listening post has nothing to do with the fixes I would like to ask someone else to test Operation Anchorage DLC since mine seems to be weird .

sesom
sesom's picture
Team Member
Offline
Last seen: 1 year 10 months ago
Joined: 09/20/2012 - 12:16
Karma: 611
While waiting for the 2.0

While waiting for the 2.0 release ;) Here are the fixes for entering and leaving Anchorage.

 

 

File Attachments: 

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 4 months 2 weeks ago
Joined: 09/11/2012 - 17:33
Karma: 3778
Thanks Sesom!

Thanks Sesom!

chucksteel
chucksteel's picture
Team Member
Offline
Last seen: 7 months 2 weeks ago
Joined: 08/15/2012 - 08:20
Karma: 1842

Issue changes: 

Status: Verified » Closed (merged)
Kleeth
Kleeth's picture
Offline
Last seen: 4 years 3 months ago
Joined: 06/25/2013 - 04:51
Karma: 0
sesom wrote:

sesom wrote:

While waiting for the 2.0 release ;) Here are the fixes for entering and leaving Anchorage.

 

 

This fix worked for me, but it also removed all my items when exiting the simulation. I should note that I'm not getting a CTD, but after General Jingwei is killed I am unable to talk to talk to General Chase to end the simulation. Is there away around this without having to lose my whole inventory?
JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 4 months 2 weeks ago
Joined: 09/11/2012 - 17:33
Karma: 3778
You mean it takes all of your

You mean it takes all of your real world stuff? Or it takes all of your sim stuff?

chaoskishin
chaoskishin's picture
Offline
Last seen: 4 years 3 months ago
Joined: 07/02/2013 - 18:19
Karma: 9
I was unable to exit (no

I was unable to exit (no crash) but got around it with the end crash fix. While the sim items are removed like they're supposed to, when I exit the simulation my real world items are not returned to me. When the bunker loads up I'm left sitting butt-nekkid in the pod with only my quest items remaining.

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 4 months 2 weeks ago
Joined: 09/11/2012 - 17:33
Karma: 3778
I've had that happen in the

I've had that happen in the past, usually if I hang around for a moment they are all returned to me. Did you give it a couple seconds?

chaoskishin
chaoskishin's picture
Offline
Last seen: 4 years 3 months ago
Joined: 07/02/2013 - 18:19
Karma: 9
yeah, I looked around the

yeah, I looked around the bunker for a few minutes to see if maybe it had been stuck I could find. It's possible that I just didn't give it enough time, but you'd think it wouldn't take more then a few seconds.

Mr Zog
Mr Zog's picture
Offline
Last seen: 4 years 3 months ago
Joined: 07/16/2013 - 16:41
Karma: 0
I have had the same issue as

I have had the same issue as chaoskisin, SIM would not end but I was not getting a crash, I tried the fix anyway, now SIM ends but I get none of my equipment back.

tommyboyca17
tommyboyca17's picture
Offline
Last seen: 4 years 3 months ago
Joined: 07/16/2013 - 16:56
Karma: 0
ok i found out how to fix

ok i found out how to fix this use the fixes and when u get to the end of the sim but before u are telliported back save and quit, then turn off fix. when u load the save u should be looking at the fading white light then a load screen. 

 

Mr Zog
Mr Zog's picture
Offline
Last seen: 4 years 3 months ago
Joined: 07/16/2013 - 16:41
Karma: 0
tommyboyca17 wrote:ok i found

tommyboyca17 wrote:

ok i found out how to fix this use the fixes and when u get to the end of the sim but before u are telliported back save and quit, then turn off fix. when u load the save u should be looking at the fading white light then a load screen. 

Fantastic, this worked for me.

Thanks

Risewild
Risewild's picture
Administrator
Offline
Last seen: 28 min 58 sec ago
Joined: 10/01/2012 - 02:14
Karma: 3191

Issue changes: 

Status: Closed (merged) » Ready to Merge
Fatalmasterpiece
Fatalmasterpiece's picture
Offline
Last seen: 4 years 3 weeks ago
Joined: 09/12/2013 - 19:47
Karma: 0
Can confirm that while

Can confirm that while running 2.0 I had the problem with Chase telling me Good job but not being able to exit. The fix esp allowed me to exit the simulation but I have the same problem of not getting any of my stuff back. Several minutes of waiting and my character is still as naked as a baby :/

 

Superpan2256
Superpan2256's picture
Offline
Last seen: 3 years 1 week ago
Joined: 01/25/2013 - 16:48
Karma: 0
Same problem here, I really

Same problem here, I really hope someone fixes this soon...

 

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 4 months 2 weeks ago
Joined: 09/11/2012 - 17:33
Karma: 3778
Read the posts just a couple

Read the posts just a couple above yours, someone found a workaround for now.

Superpan2256
Superpan2256's picture
Offline
Last seen: 3 years 1 week ago
Joined: 01/25/2013 - 16:48
Karma: 0
Sorry, did not see that.

Sorry, did not see that. Thank you!

Pages