15 posts / 0 new
Last post
Risewild
Risewild's picture
Administrator
Offline
Last seen: 2 hours 27 min ago
Joined: 10/01/2012 - 02:14
Karma: 3316
Unlootable Protectron Robots

In the Robot Repair Center (The Mechanist HQ near CC) there are some Protectron robots we can activate from their pods, they seem to be unlootable after dying.

Category: 

Bug report

Component: 

Creatures

Priority: 

Minor

Status: 

Closed (merged)

Project: 

Tale of Two Wastelands

Version: 

TTW 2.7

Reporter: 

Risewild

Created: 

Fri, 02/21/2014 - 20:48

Updated: 

Thu, 12/18/2014 - 14:38
Edited by: TJ on 12/18/2014 - 14:38
KeltecRFB
KeltecRFB's picture
Trusted Poster
Offline
Last seen: 1 week 3 days ago
Joined: 08/19/2013 - 12:54
Karma: 895
Donor
To add, I think all of the

To add, I think all of the Robots in the Capital Wasteland (thus far) can not be looted.  I activated RobCo Certified and I was unable to look into the inventory of the entry level Mr. Gutsy when I clicked on it.  The choice menu comes up, however when I clicked search, it sent me directly to take or leave choices.  Even if there is nothing in the inventory, it usually opens a inventory window in FONV.

Risewild
Risewild's picture
Administrator
Offline
Last seen: 2 hours 27 min ago
Joined: 10/01/2012 - 02:14
Karma: 3316
KeltecRFB wrote:

KeltecRFB wrote:

 

To add, I think all of the Robots in the Capital Wasteland (thus far) can not be looted.  I activated RobCo Certified and I was unable to look into the inventory of the entry level Mr. Gutsy when I clicked on it.  The choice menu comes up, however when I clicked search, it sent me directly to take or leave choices.  Even if there is nothing in the inventory, it usually opens a inventory window in FONV.

It seems mod related, since I can loot any robot I destroy with a vanilla TTW install (with the exception of the ones I mentioned here ).

The Bug tracker is for vanilla TTW bugs only, for other bugs please use the forum .

Risewild
Risewild's picture
Administrator
Offline
Last seen: 2 hours 27 min ago
Joined: 10/01/2012 - 02:14
Karma: 3316

Issue changes: 

Status: Needs Playtesting » Unverified
thermador
thermador's picture
Administrator
Offline
Last seen: 2 days 19 hours ago
Joined: 08/07/2012 - 07:24
Karma: 1172
Donor
Risewild wrote:

Risewild wrote:

In the Robot Repair Center (The Mechanist HQ near CC) there are some Protectron robots we can activate from their pods, they seem to be unlootable after dying.

Just checked with vanilla 2.7.3.  This is indeed the case.  It only applies to the two Protectron robots that stay "alive" after you open their pods (and don't immediately collapse).  Given that this applies to two robots in the entire game, and only if you kill them with friendly fire, which you aren't supposed to do, I'm marking this bug as minor.  It may in fact be a vanilla bug, but I can't find anything about it on the Fallout Wiki either.

Issue changes: 

Priority: Normal » Minor
Status: Unverified » Verified
TJ
TJ's picture
Team Member
Offline
Last seen: 5 months 2 weeks ago
Joined: 09/17/2012 - 06:06
Karma: 2845
Donor
Next time someone is in the

Next time someone is in the area can you please get me a refID and a baseID?

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 7 months 3 weeks ago
Joined: 09/11/2012 - 17:33
Karma: 3778
There is also a new NVSE

There is also a new NVSE function, GetBaseForm, I haven't tested it in game yet but I THINK it works on leveled references (which normally return the formID of the leveled list it was chosen from, or something like that).

Risewild
Risewild's picture
Administrator
Offline
Last seen: 2 hours 27 min ago
Joined: 10/01/2012 - 02:14
Karma: 3316
For one Protectron:

For one Protectron:

  • RefID: 0a0a4441
  • BaseID: 0a0a4447 (Protectron)

For the other Protectron:

  • RefID: 0a0a445a
  • BaseID: 0a0a53f0 (Protectron)

 

thermador
thermador's picture
Administrator
Offline
Last seen: 2 days 19 hours ago
Joined: 08/07/2012 - 07:24
Karma: 1172
Donor
Nope, still not lootable with

Nope, still not lootable with that patch active in the load order.  Even tried loading a game before I entered the robot repair center, waited 4 game days in an interior, then went to the repair center.  No change.

Risewild
Risewild's picture
Administrator
Offline
Last seen: 2 hours 27 min ago
Joined: 10/01/2012 - 02:14
Karma: 3316
Therm is right, they still

Therm is right, they still have the problem even with the fix file .

Risewild
Risewild's picture
Administrator
Offline
Last seen: 2 hours 27 min ago
Joined: 10/01/2012 - 02:14
Karma: 3316

Issue changes: 

Status: Needs Playtesting » Verified
TJ
TJ's picture
Team Member
Offline
Last seen: 5 months 2 weeks ago
Joined: 09/17/2012 - 06:06
Karma: 2845
Donor
Totally my fault. Try this

Totally my fault. Try this one.

File Attachments: 

Issue changes: 

Status: Verified » Needs Playtesting
Risewild
Risewild's picture
Administrator
Offline
Last seen: 2 hours 27 min ago
Joined: 10/01/2012 - 02:14
Karma: 3316
Works like a charm now .

Works like a charm now .

Risewild
Risewild's picture
Administrator
Offline
Last seen: 2 hours 27 min ago
Joined: 10/01/2012 - 02:14
Karma: 3316

Issue changes: 

Status: Needs Playtesting » Ready to Merge
TJ
TJ's picture
Team Member
Offline
Last seen: 5 months 2 weeks ago
Joined: 09/17/2012 - 06:06
Karma: 2845
Donor
Merged in r282.

Merged in r282.

Issue changes: 

Status: Ready to Merge » Closed (merged)