29 posts / 0 new
Last post
pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
Invisible Pipboy

So the hotfixes on the download page caused an issue where the game would freeze upon trying to enter moriarty's saloon. So I downloaded TTW Fixes which solved that problem, but not my pipboy is invisible (part of arm is indivisible too) and there is this white floating square upon trying to open it. I tried looking around but couldn’t find any posts on what I’m experiencing.

Windows 10, Intel Core i5-6500 CPU @ 3.20GHz, 8GB RAM

FOMM ver 0.14.13

Steam Download/F3 and FNV GOTY editions

edit: so it seems that TTWFixes is specifically causing my issues with the pipboy being invisible, as it works fine without the patch, but I have no idea why as nobody has reported an issue like this before. :-(

Stuff I have tried so far:

-removing and reloading the pipboy

-making ini core adjustments

-removing TTW fixes (pipboy is now fine, but crash upon entering moriarty's saloon every time)

-enabled achieve invalidation

-redownloaded TTW fixes

-double checking ini files are not read only

-double checking no mods are installed by NMM from when I used to use that

File Attachments: 

TTW Version Compatibility: 

v2.9

Rating: 

0
Your rating: None
0
No votes yet
Edited by: pentelo on 12/10/2017 - 14:24
RoyBatty
RoyBatty's picture
Administrator
Offline
Last seen: 10 hours 59 min ago
Joined: 04/27/2014 - 03:26
Karma: 5692
Donor
Everything looks fine.

Everything looks fine.

open the console and try this

player.removeitem 15038

player.additem 15038

player.equipitem 15038

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
Thanks for replying, I gave

Thanks for replying, I gave that a try (with quantity amounts) that but it didn't help. I attached a picture of what it looks like, not sure if that will help. 

File Attachments: 

Mystical Panda
Mystical Panda's picture
Offline
Last seen: 3 hours 32 min ago
Joined: 03/30/2016 - 07:02
Karma: 715
If you remove the pipboy

If you remove the pipboy using the above command does your arm look ok? Does the pipboy look the same from different perspectives- like from a 3rd person instead of 1st? or does it still show a large white box where the pipboy should be?

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
When it's removed the arm is

When it's removed the arm is still invisible but there is no white box (it's more like a flat semi transparent white shape actually). And yes first and third POV are the same, white box when equipped, no white box when removed. edit: the pipboy was working up until I added the TTW fixes (https://taleoftwowastelands.com/content/ttw-fixes-222-official-bugfix-pa...), so I think something in there might be interfering with the model/texture, or I mght have done something incorrectly? I only have one mod installed besides TOTW, hotfixes, and TTW fixes and that's TTW essential companions. 

Mystical Panda
Mystical Panda's picture
Offline
Last seen: 3 hours 32 min ago
Joined: 03/30/2016 - 07:02
Karma: 715
pentelo wrote:

pentelo wrote:

 

When it's removed the arm is still invisible but there is no white box (it's more like a flat semi transparent white shape actually). And yes first and third POV are the same, white box when equipped, no white box when removed. edit: the pipboy was working up until I added the TTW fixes (https://taleoftwowastelands.com/content/ttw-fixes-222-official-bugfix-pack-ttw), so I think something in there might be interfering with the model/texture, or I mght have done something incorrectly? I only have one mod installed besides TOTW, hotfixes, and TTW fixes and that's TTW essential companions. 

k, just checking. Some of my pipboy shots seemed stretched out for some reason, and was wondering if it looked the same or slightly different from a different perspective on yours. I'm not sure on the fixes, if you uninstall the ttw fixes does it correct the problem your having with the pipboy? 

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
If I disable TTW fixes the

If I disable TTW fixes the the pipboy works fine, but then I crash when trying to enter moriarty's saloon. I'm going to try starting a new game and see if that helps at all.

Mystical Panda
Mystical Panda's picture
Offline
Last seen: 3 hours 32 min ago
Joined: 03/30/2016 - 07:02
Karma: 715
pentelo wrote:

pentelo wrote:

 

If I disable TTW fixes the the pipboy works fine, but then I crash when trying to enter moriarty's saloon. I'm going to try starting a new game and see if that helps at all.

Good luck- I wish I was able to help you more. A quick search on the problem had solutions like deleting Gob, and many others which shouldn't really apply or be used. I'm testing out Fallout NV, with my TTW build on a completely different pc. Maybe if I can get some free time, I can move that on this one where I can try and help test some of these things out. I've heard it's been fixed for the new release, but if we knew what the fix was, a patch could more than likely be made fairly quickly just to address this. 

GrantSP
GrantSP's picture
Trusted Poster
Offline
Last seen: 10 hours 21 min ago
Joined: 01/08/2017 - 15:13
Karma: 132
That screenshot looks like it

That screenshot looks like it is displaying a missing texture marker for the pipboy.

Are you sure you're not missing a BSA or you used and now removed a PipBoy replacer incorrectly?

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
I doubt it, it's a completely

I don't think so, it's a completely fresh install of FNV, f3 and TTW, with only TTW fixes, TTW hotfixes, and TTW Essential companions install. The pipboy works correctly if I uninstall TTW Fixes.

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
Okay so I tried starting a

Okay so I tried starting a fresh game, same issue, and also the white thing appeared in the character creation screen. along with a semi translucent red plane that transects the head. idk

File Attachments: 

Mystical Panda
Mystical Panda's picture
Offline
Last seen: 3 hours 32 min ago
Joined: 03/30/2016 - 07:02
Karma: 715
pentelo wrote:

pentelo wrote:

 

Okay so I tried starting a fresh game, same issue, and also the white thing appeared in the character creation screen. along with a semi translucent red plane that transects the head. idk

That almost looks like a missing mesh of some kind- like when you zoom really close in. I wonder if somehow the download has been corrupted, either at the client or server level? I have an older copy of TTW 2.9.4 (I believe), it might be worth taking the time and hashing it, then compare the value to see if there's a difference in hopes of tracking down what might be causing this.

If your using symlinks, from what I've discovered, it only worked (at least for me) with loose files; it didn't work with plugins and bsas. One symptom was with the "Hope Lies" companion- she had arms, legs and one giant red triangle for a body. The mod had both a bsa archive and loose files. The loose files didn't work, the bsas did. I restarted the mod manager as admin, then I could properly create the symlinks for the loose files. It a catchy thing that can crop up without noticing. 

RoyBatty
RoyBatty's picture
Administrator
Offline
Last seen: 10 hours 59 min ago
Joined: 04/27/2014 - 03:26
Karma: 5692
Donor
Missing mesh marker, did you

Missing mesh marker, did you enable archive invalidation?

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
Panda - I'm pretty sure I'm

Panda - I'm pretty sure I'm not using symlinks, unless any are used by TTW. The only texture that seems to be affected in game is the pipboy, which is sad because I can't play without that. I might try reinstalling some stuff and seeing if that helps. It's just so weird that it only happens with TTW fixes loaded. 

RoyBatty - I did forget to do that but it unfortunately didn't help either. Do you know of any way to fix the moriarty saloon crash with the TTW fixes patch?

 

edit: attached photos from 3rd person POV and with removed pipboy, the red plane is also in game from certain angles (caused by pipboy) and the character appears bald and helmet-less from behind, but fine from below/the front. 

edit2: another question, I've double checked and non of my ini files are read only, but when I open NMM (to double check no mods are being loaded from there) it says my fallout ini is read only and do I want to make it non read only, but I can't figure out what file that is referring to as all 3 inis for f3 and fnv are non read only? It asks this every time it's opened. 

File Attachments: 

Nostalgia
Nostalgia's picture
Offline
Last seen: 14 hours 51 min ago
Joined: 11/14/2017 - 10:14
Karma: 69
Donor
My guess is something to do

My guess is something to do with archive invalidation- like Roy said. I get missing meshes/textures sometimes for no apparent reason and have to toggle it to make things work again. 2 mods I had installed had missing meshes/textures everywhere for awhile and then started to work for me after I left them there through several saves and toggles of archive invalidation I did for other stuff. Maybe something about the game cache?

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
Nostalgia - I'll try toggling

Nostalgia - I'll try toggling it more and creating some new saves, thanks for the tip

edit: did it a few times, doesn't seem to help

Mystical Panda
Mystical Panda's picture
Offline
Last seen: 3 hours 32 min ago
Joined: 03/30/2016 - 07:02
Karma: 715
No TTW doesn't do symlinks

No TTW doesn't do symlinks natively, but I wasn't sure if that was done manually. Ok we can rule that one out.

Is there a way you can go into the console and click on the missing texture/mesh (the big white box like thing), then enter GBO for (get base object). What object id is it showing? is the same for the pipboy? The first two digits of the base object id should point the plugin it's looking for.

RoyBatty
RoyBatty's picture
Administrator
Offline
Last seen: 10 hours 59 min ago
Joined: 04/27/2014 - 03:26
Karma: 5692
Donor
You're the only person in

You're the only person in like 3 years to have this issue, are you sure you didn't have YUP or something else installed before? A pipboy retexture? anything?

It is not a missing texture, it is a missing model for the pipboy. Try verifying your NV cache in steam (back up your ini files first as this will reset them).

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
Panda - In 1st person the

Panda - In 1st person the white blob has no id, in 3rd person the red/white blob all registers as the player character (14). 

RoyBatty - I freshly installed FNV and F3 before installing TTW, I had TTW installed like 6 months back and it was working okay (just crashing sometimes like the games usually do), but I had uninstalled FOMM and F3 because I forgot I was using them for TTW, and when I came back to it I did a fresh install of everything. Maybe that could have something to do with it? I'm fairly sure all the old files were gone for F3/FNV/TTW before I reinstalled. I've never had any other mods installed for FNV, but I did have some installed with F3 on NMM (uninstalled now), not sure if that's relevant.

I'll verify my NV cache and edit this post after I'm done. 

edit: Also thank you both for taking the time to help me with this.

edit 2: Verified game cache, 2 files were bad (so 1), but the issue is still happening. 

RoyBatty
RoyBatty's picture
Administrator
Offline
Last seen: 10 hours 59 min ago
Joined: 04/27/2014 - 03:26
Karma: 5692
Donor
question, are you playing a

question, are you playing a male or female character?

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
Female, also edited my

Female, also edited my previous post

Mystical Panda
Mystical Panda's picture
Offline
Last seen: 3 hours 32 min ago
Joined: 03/30/2016 - 07:02
Karma: 715
Let me think about this for a

Let me think about this for a second and see if I can come up with something 'programmatic' we might be able to use in the long run to potentially help with things like this.

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
Panda - I'm sure it's not a

Panda - I'm sure it's not a problem with the files since I'm the only one having this issue, but I have no idea what's gone wrong. When I have some extra time I may remove and redownload TTW, or see if I can get it to not crash when trying to enter moriarty's saloon without the fixes patch. 

RoyBatty
RoyBatty's picture
Administrator
Offline
Last seen: 10 hours 59 min ago
Joined: 04/27/2014 - 03:26
Karma: 5692
Donor
See if this fixes it.  

See if this fixes it.

 

File Attachments: 

pentelo
pentelo's picture
Offline
Last seen: 1 month 1 week ago
Joined: 12/08/2017 - 23:21
Karma: 17
It works, thank you so much!

It works, thank you so much! I really appreciate you guys taking helping me for like three days with this! Hopefully there will be no more eventful bugs. :-)

Mystical Panda
Mystical Panda's picture
Offline
Last seen: 3 hours 32 min ago
Joined: 03/30/2016 - 07:02
Karma: 715
pentelo wrote:

pentelo wrote:

 

Panda - I'm sure it's not a problem with the files since I'm the only one having this issue, but I have no idea what's gone wrong. When I have some extra time I may remove and redownload TTW, or see if I can get it to not crash when trying to enter moriarty's saloon without the fixes patch. 

It's absolutely no problem at all- I was thinking about creating a quick utility to check for missing assets in general any ways. It won't quite be as refined at first, but as I get more time and build more libraries for parsing records I'll be able to refine it more. 

GrantSP
GrantSP's picture
Trusted Poster
Offline
Last seen: 10 hours 21 min ago
Joined: 01/08/2017 - 15:13
Karma: 132
Interesting. So was it the

Interesting. So was it the change from BigGuns to BodyWear or the restoration of the *.nif for the female character that fixed it?

Based on Roy's previous question I'm going to assume the NIF.

RoyBatty
RoyBatty's picture
Administrator
Offline
Last seen: 10 hours 59 min ago
Joined: 04/27/2014 - 03:26
Karma: 5692
Donor
The nif is named wrong

The nif is named wrong because of YUP, also that "fix" is broken anyways because it edits the position of the pipboy to "fix" an issue with some of the armors. The issue it's trying to actually fix is because those armors have no female mesh so the arms are in a different position, the effect is that it breaks the female armors so it's tit for tat.

As for the effect mesh on the pipboy being green instead of amber like new vegas' hud, I don't think that's a fix since you can change the hud color to green (which I do). And you can just use Sarge198's mod to change the pipboy color to different colors and they don't break the female armors in the process.

I have removed this "fix" from YUP for TTW 3.0, and we will work on creating female versions of the armors that have this issue instead.

Frobozz
Frobozz's picture
Offline
Last seen: 2 weeks 14 hours ago
Joined: 02/10/2018 - 14:46
Karma: 1
I recently set up ToTW for

I recently set up ToTW for the first time, and I ran into the invisible Pip-Boy problem myself. When I finally found this thread, the pipboytest plugin fixed it when nothing else would. Thank you for this.