25 posts / 0 new
Last post
Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
2 Questions about 2.0

doing a completely fresh install of nv and decided to use ttw and build my mods around it this time, and have 2 questions. first would be, the installer is running, but in the installer window these 3 lines bother me

"your version of taleoftwowastelands-main.bsa cannot be patched"

then right below it it has "taleoftwowastelands-main.bsa could not be found in <my fallout 3 directory>"

then it has "taleoftwowastelands-Main.bsa failed to patch properly."

but it just keeps on installing, are those errors going to cause a problem, or is it just letting me know i didnt have ttw installed already and it needed to make a new main.bsa?

 

and my other question is about using fallout 3 mods, i went into the faq section and it had a decent amount of info on getting them to work, but its crossed out with a no longer applicable as of 2.0 stamped on it, i guess im looking for clarification. does that mean i can just use fallout 3 plugins like nv ones, is there a different procedure to installing them than that now, or can we just not use fallout 3 plugins with 2.0 at the moment?

Rating: 

0
Your rating: None
0
No votes yet
chucksteel
chucksteel's picture
Team Member
Offline
Last seen: 8 months 3 weeks ago
Joined: 08/15/2012 - 08:20
Karma: 1842
1. The errors are a problem

1. The errors are a problem that many people including myself have had. Update you Visual C++ to Visual C++ 2012. Make sure you update to the version that is apropreate for your system. meaning if you have a 32 bit system use the x86 version and if you have a 64 bit system use the x64 version. 

Also update your .Net framework to the latest version. 

If your still getting the errors after that you'll have to wait a bit. Jax is working on a fix for the install issue and it should be out soon. 

 

2. You can still use FO3 mods the conversion process is different and you can find the instructions here. I am working on a PDF tutorial with step by step picture instruction and should have it finished sometime today. 

Don't just drop FO3 mods into your game because all you will do is crash when you attempt to play. 

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
i have all my c++ and net

i have all my c++ and net updated, the installer wouldnt start until i did, and it did make the main.bsa and is still installing and making all the files it needs despite the messages, i guess my question is once its finished, am i going to have to install it all over again or not, since the program is  still making all the files it needs.

i guess the best way to tell that would be to know if the bsa is complete or if it stopped short,

the only one that produced any messeges was the TaleOfTwoWastelands - Main bsa which is clocked in at 675,327 kb, is that the right amount of data for that particular file or did it really mess up?

dawe1313
dawe1313's picture
Trusted Poster
Offline
Last seen: 9 months 3 weeks ago
Joined: 03/21/2013 - 21:39
Karma: 174
2nd answer first: http://www

2nd answer first: http://www.taleoftwowastelands.com/content/ttw-20-out

in the OP, just under the load order example, Jax has some instructions for converting FO3 mods for TTW use. chucksteel is working on a more in depth version, but hasn't gotten it finished yet

answering the 1st: without the main bsa you will have missing textures, meshes, etc. the TTW team has put together quite a few custom meshes/textures for TTW.

putting the installer in a folder on the root , i.e. "C:\ttwinstaller212" and setting the output to a new, empty folder on the root of your hard drive, i.e. "C:\TTWMod", (instead of installing directly into your FNV folder) seems to be the way that most people are having the least problems with. after the installer finishes, which can take a long time depending on your system hardware (around 45 minutes is the least i've seen reported) you can copy the folders contents into your FNV install directory.  the TTW files are a little bit over 7GB, so this can take a while. (this way also has the benefit making it easier to reinstall, if necessary.

also, starting with totally clean installs of FO3 & FNV works best. (uninstall all mods, uninstall games, delete old installation folders for both, then reinstall)

from the download page:

run windows update and make sure everything has the latest updates

hope this helps

 

Dashael
Dashael's picture
Offline
Last seen: 4 years 3 months ago
Joined: 02/28/2013 - 00:42
Karma: 9
Having the same issue. I

Having the same issue. I endured with the install anyway, and when I got into the game I noticed some graphical issues: 

No mods installed so Gomez's outfit and the scrambled junk on the noticeboard have to be TTW errors

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
im not sure you understand

dawe1313, not to be rude, but im not sure you understand what im saying, i realize without the bsa things will be missing, im not new to modding, but as i already stated, its telling me it cant be patched but then still producing ALL the files that are needed to run the mod, including said bsa that had told me it failed to patch, it spat out a data folder with all the bsa archives for ttw, and the 5 dlc for fallout 3, as well as all the esm/p files, the folder is 7.72 gigs, my whole questions has been, what does it mean when it tells me it cant patch a certain file in the ttw installer, and will that actually hurt something?

chucksteel
chucksteel's picture
Team Member
Offline
Last seen: 8 months 3 weeks ago
Joined: 08/15/2012 - 08:20
Karma: 1842
Your Tale of Two Wastelands

Your Tale of Two Wastelands Main .bsa didn't patch properly. try running the installer again. 

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
ive ran the installer about 4

ive ran the installer about 4 times, it jsut keeps telling me the bsa cant patch, i completely removed new vegas before startign this but hadnt done the same to fallout 3, might as well do a fresh dump of that as well, maybe some old mods i had in fallout 3 altered some files so that its not picking up o them in the patcher.

chucksteel
chucksteel's picture
Team Member
Offline
Last seen: 8 months 3 weeks ago
Joined: 08/15/2012 - 08:20
Karma: 1842
Jax is working on a fix for

Jax is working on a fix for the installer. This type of error is happening to a lot of people. The TTW 2.0 release has ben a bit rough but we are working on the problems, You may just have to wait for the next version which will be out as soon as jax can get it done. 

dawe1313
dawe1313's picture
Trusted Poster
Offline
Last seen: 9 months 3 weeks ago
Joined: 03/21/2013 - 21:39
Karma: 174
no prob, was just trying to

no prob, was just trying to be as complete as possible with my answer. i, also, did not mean to offend

 

my TaleOfTwoWastelands - Main.bsa is showing at 690,142KB

 

chucksteel
chucksteel's picture
Team Member
Offline
Last seen: 8 months 3 weeks ago
Joined: 08/15/2012 - 08:20
Karma: 1842
You didn't offend, No worries

You didn't offend, No worries about that. 

the error is a pain because it is somewhat random meaning some people with the same system don't have the issue others do. 

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
alright, so my bsa is in fact

alright, so my bsa is in fact missing about 15 mb, so i guess if a fallout 3 fresh install doesnt work its the waiting game for me

dawe1313
dawe1313's picture
Trusted Poster
Offline
Last seen: 9 months 3 weeks ago
Joined: 03/21/2013 - 21:39
Karma: 174
i think the installer,

i think the installer, actually windows, may be having issues with character counts in long file names, which is why i suggested putting the installer and output folder straight on the root of the hard drive.  that could be an explanation of the intermittent nature of the problem

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
fresh install of both fallout

fresh install of both fallout games and had it install to a directory on my desktop, still telling me my version of main .bsa cant be patched, i do have a different question though, how come the installer keeps trying to find the ttw bsa files in the fallout 3 directory, it outputs

"taleoftwowastelands-Main.bsa could not be found in <fallout 3 install directory>"

and then proceeds to patch wrong, is there any particular reason its trying to locate all the self created ttw bsa files in the fallout 3 directory?

alegendv1
alegendv1's picture
Offline
Last seen: 1 year 8 months ago
Joined: 12/22/2012 - 09:48
Karma: 136
Well, im on Win7 x64, but

Well, im on Win7 x64, but this is what I did. 1st try for install, (note: installed into FNV directory, some people have more success installing to separate place). I get a pop-up error saying that TTW. Main bsa failed to patch and that I should post on bug forum. Well the installation still attempted to continue, so I actually cancelled it. Then I figured, why not try it again, just to be sure before I post. It runs through second time with no issues. I don't know if this will help you, but that's what I did. You're using 2.2, i'm assuming.

Just noticed u said the TTW bsas are being searched for in FO3 directory? I'm not sure if thats supposed to be the case... try asking on public chat, someone might have an answer.

And if a directory is in C drive, probably best to run program as admin.

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
yea im on the same os as you

yea im on the same os as you are, but it just plain old keeps failing to patch, i did read somewhere here that yanking all your c++ redist files and only installing the most recent might help, but i would have to go look up how to do that, im not one to just remove system files all willy-nilly, other than that im clueless, i never did get 1.4 to run on my machine but at least it would install then fail afterwards, not the other way around

 

*well damn, someone snuck in and changed the installer version on the download page since 3 am yesterday when i downloaded the installer, put my bullshit on hold untill i try this newer version, i wasnt expecting it to be updated in less than a day since i downloaded it.

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 2 weeks 3 days ago
Joined: 09/11/2012 - 17:33
Karma: 3778
I'm just that good.

I'm just that good.

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 2 weeks 3 days ago
Joined: 09/11/2012 - 17:33
Karma: 3778
I'm just that good.

I'm just that good.

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
yea......it all worked fine,

yea......it all worked fine, 0 errors, so whatever 2.2 did that was different from 2.12 fixed it for me, might help to clarify that a new version of the installer is up instead of just deleting the 1 out of the donwload file name lol.

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 2 weeks 3 days ago
Joined: 09/11/2012 - 17:33
Karma: 3778
I announced in chat. Had mean

I announced in chat. Had mean to make a new post. Forgot. For the record, I shoot for weekly updates. Daily, when its critical.

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
i had one more quick question

i had one more quick question and i figured why not just tack it on here instead of making a whole new post.

i know that custom races dont get along with a few parts of the mod, so i was wondering to circumvent that could i just tell say for example, the default caucasian race to reference the meshes and textures of the custom race i want in nvedit, effectivly allowing me to use said custom race but it still being a "default race"?

i know that would change all the others labeled caucasian in game to refrencing the custom race data as well, but it being mohave delight i dont see that as a downside really.

JaxFirehart
JaxFirehart's picture
Administrator
Offline
Last seen: 2 weeks 3 days ago
Joined: 09/11/2012 - 17:33
Karma: 3778
Each race links to other

Each race links to other races that is says are its "Old" and"Child" versions. The best way to do it is to duplicate an existing child race and tell it that its Adult version is your custom race and tell your custom race that its child version is the duplicate you just created. That way when you start in V101 you age up properly and when you do tranquility lane it is able to make you a child and then an adult again with no issues.

Bashis
Bashis's picture
Offline
Last seen: 4 years 6 months ago
Joined: 12/07/2012 - 10:07
Karma: 29
oooh, that makes sense, ill

oooh, that makes sense, ill have to look into how to do that, there was no child/adult links in oblivion, which is where 3/4ths of my modding exp came from, but it shouldnt be that hard to figure out.

 

so the only reason custom races didnt get along with ttw is that they didnt have child counterparts? seems like using the fallout 3 version of that custom race would make more sense, as they funtioned in vault 101 and tranq lane when i played fallout 3 with em, making me think they have the child connection already made.

LaEspada
LaEspada's picture
Offline
Last seen: 1 year 6 days ago
Joined: 07/11/2013 - 21:00
Karma: 106
Hmm. So I was using my own

Hmm. So I was using my own custom race mod with the child/adult counterparts set up like vanilla races do. and after I finished tranquility lane it reset my character to a the Caucasian race not my custom race since my character's looks changed completely. I also tested it at the beginning since I noticed this as well. When you create your character at the very beginning and go through the whole process until the point where you are escaping from the vault It doesn't revert back to the custom race. it keeps setting my character to Caucasian race, not my custom race that I had created in char gen menu.

 

7ty7
7ty7's picture
Offline
Last seen: 3 years 4 months ago
Joined: 06/18/2014 - 12:30
Karma: 4
Sorry to necro this, but in

Sorry to necro this, but in case someone is wondering what happened to the last poster, I think it is the following:

Each race has a child race assigned. But each child race also has an older race asigned. So copy a vanilla child race, and make that copied child have an older race (your custom race) and in turn have your custom race that copied child as young race.

I'm guessing the last poster assigned a child race to his custom race but when it was time to revert to old guy again, his child race had vanilla caucasian assigned as older race, not his former custom race.

If this necro is too much, we could merge this thread with my cutom race questions thread, which is pretty recent and offers a few solutions for custom races thanks to farmerboy and thermador.